VDisk unter Oracle VirtualBox vergrößern

Wir haben eine uralte Win-XP Installation laufen für Testzwecke, die hat eine VDisk mit 10G.
Diese virtuelle Platte ist nun zu klein und soll auf 20GByte verdoppelt werden. An sich geht das recht leicht mit dem Befehl: modifyhd  (bzw in neueren Versionen mit dem universelleren Commando  „modifymedium“ )

 

Zuerst mal die UUID von der Disk holen:

>  cd  "C:\Users\<username>\VirtualBox VMs\Windows XP"

> "C:\Program Files\Oracle\VirtualBox\VBoxManage" list hdds
UUID: 78d5b2b4-be2f-49b2-8778-05f875595c8d
Parent UUID: base
State: created
Type: normal (base)
Location: C:\Users\<username>\VirtualBox VMs\Windows XP\Windows XP.vdi
Storage format: VDI
Capacity: 10240 MBytes
Encryption: disabled

 

Mit dem Versuch diese Disk von 10GByte auf 20GByte zu vergrößern, bekommt man folgenden Fehler:

> "C:\Program Files\Oracle\VirtualBox\VBoxManage" modifymedium 78d5b2b4-be2f-49b2-8778-05f875595c8d --resize 20480
0%...
Progress state: VBOX_E_NOT_SUPPORTED
VBoxManage.exe: error: Resize medium operation for this format is not implemented yet!

 

Das lässt sich lösen indem man einfach diese Disk zuerst clont, dann vergrößert und dann „normalisiert“:

> "C:\Program Files\Oracle\VirtualBox\VBoxManage" clonemedium disk 78d5b2b4-be2f-49b2-8778-05f875595c8d disk_new.vdi
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Clone medium created in format 'VDI'. UUID: 0b0ef445-786f-4824-987c-6ff8701d6be5

 

Nun die tatsächliche Vergrößerung der VDisk, der Parameter bei resize ist die neue Größe im MByte, also 20GByte in unserem Beispiel:

> "C:\Program Files\Oracle\VirtualBox\VBoxManage" modifymedium disk disk_new.vdi --resize 20480
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

 

Nun haben wir schon die neue Disk „disk_new.vdi“, allerdings ist sich noch nicht voll „aufgeblasen“ auf die neue Größe von 20GByte.

> dir
Datenträger in Laufwerk C: ist System
Volumeseriennummer: CE8B-D156

Verzeichnis von C:\Users\<username>\VirtualBox VMs\Windows XP

09.04.2021 13:49 <DIR> .
09.04.2021 13:49 <DIR> ..
09.04.2021 13:50 10.225.713.152 disk_new.vdi       <-- neue Disk (20G, noch nicht "aufgeblasen")
09.04.2021 11:02 <DIR> Logs
08.04.2021 12:33 <DIR> Snapshots
09.04.2021 13:49 7.110 Windows XP.vbox
09.04.2021 13:34 7.110 Windows XP.vbox-prev
09.04.2021 13:45 10.739.515.392 Windows XP.vdi    <-- alte Disk (10G)

 

eventuell kann der folgende Schritt entfallen, ich hab es aber so versucht und hat gut funktioniert. Der Prozess hat hier recht lange gedauert, nach den ersten 10% ging es dann schneller:

"C:\Program Files\Oracle\VirtualBox\VBoxManage" clonemedium disk disk_new.vdi disk_20G.vdi --variant Fixed
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Clone medium created in format 'VDI'. UUID: 7f8db0cb-9e62-41b6-8236-c6a6ed1121b7

 

Nun muss man in der VirtuelBox Konfig der VM die neue 20G Disk statt der alten 10G auswählen.

 

In nächsten Schritt dann das Tool gparted herunterladen, das ISO als Boot-CD in der VM einbinden und das Filesystem der Disk vergrößern. Wenn alles erledigt ist und die CD wieder ejecten und die VM normal booten.
Das wirklich super Tool gibts hier:  https://gparted.org/

Nun startet grundsätzlich Windows wieder, meldet jedoch eventuell eine defekte Platte und will einen DiskCheck machen. Das passt gut.

Hier sieht man leider noch nicht die neue Größe angedruckt.

 

Die Überprüfung im Explorer zeigt aber dann doch gleich den Erfolg  🙂

 

Windows 7 – das Ende naht!

Microsoft wird mit 14. Jänner 2020 den Support für Windows 7 komplett einstellen!

Damit gibt es auch keine Updates mehr für kritische Sicherheitslücken oder sonstige möglichen Probleme. Für Hacker also ein gefundenes Fressen nun auf Windows 7 Rechner los zu gehen.

Microsoft warnt und informiert seit Monaten zu dem Ende vom Support für Windows 7

Obwohl schon seit längerem bei jedem Login & Reboot Info-Dialoge angezeigt werden und zum Umstieg auf Windows 10 gedrängt wird, sind dem nur sehr wenige Firmen gefolgt. Ein Umstieg auf Windows 10 wird dringend angeraten.
Es wird Windows 7 zwar nicht funktionsuntüchig oder in der Verwendung beschnitten, aber es wird ab Mitte Jänner immer unsicherer damit noch zu arbeiten!

Hier der Link zu Microsoft mit der Ankündigung:

Windows 7 Support endet am 14. Jänner 2020 / windows 7 support will end on january 14 2020

 

Es gibt grundsätzlich drei Arten zu reagieren:

  • gar nichts tun und einfach abwarten, das Risiko in Kauf nehmen
  • auf Windows 10 umsteigen
  • auf Linux umsteigen

Wenn Informationen oder Hilfe brauchen für den Umstieg oder einen Test von einem Linux-Desktop, wir helfen gerne weiter! Schreiben Sie uns eine eMail!

Probleme mit Netzwerk nach Windows10 Update

Vor ein paar Tagen ist ein WindowsUpdate herausgekommen bei dem es zu Problemen mit der LAN und Internetverbindung kommen kann!

Das lässt sich dann recht einfach durch folgenen Vorgang beheben:

* als Admin einloggen

* CMD (Eingabeaufforderung) als Administrator ausführen

* möglicherweise kommt eine Dialogbox mit der Frage ob „Änderungen am System erlaubt werden sollen“; diese mit JA beantworten

* in der Eingabeaufforderung eingeben:

    netsh Winsock reset

* den PC neu starten

 

Eventuell müssen Sie bei manchen Netzwerkverbindungen nun nochmal eine Anmeldung durchführen.

Selbstsignierte und eigene CA & Zertifikate

Das hier soll eine kleine & unvollständige Erläuterung für den Umgang und Import von eigenen CAs und somit Zertifikaten in diversen Programmen sein.

Import für Produkte von Microsoft

Um in Outlook, Outlook Express, den Microsoft Internet Explorer (MS-IE) oder ein beliebiges anders Microsoft Produkt einen neuen SSL-Schlüssel zu importieren, öffnen Sie diese Seite bitte mit dem MS-InternetExplorer und klicken Sie weiter unten auf den Root-Zertifikat-Link.  Sie brauchen diesen neuen Schlüssel nur mit dem MS-InternetExplorer normal laden – der Importvorgang wird dabei automatisch gestartet. Danach ist das Zertifikat für alle Microsoft Produkte ohne weitere Tätigkeit verfügbar, also auch im Outlook und so weiter.
Eine genaue Anleitung gibt es natürlich auch.

Import für Produkte der Mozilla Foundation
(Firefox, Netscape, Thunderbird & SeaMonkey)

Öffnen Sie das Programm in dem Sie den Import machen möchten, also zB: Firefox, und klicken Sie auf den Link unten. Der Import startet dann automatisch.
Eine Anleitung für Firefox3 gibt es hier.
Eine Anleitung für Konquerer 4.1 gibt es hier.
Eine Anleitung für SeaMonkey gibt es hier. 

Import für das iPhone 3G

Öffnen Sie im iPhone eigenen Browser einfach den Link zu unserem Root-Zertifikat bzw klicken Sie auf den Link unten. Der Import startet dann automatisch.
Eine Anleitung für das iPhone gibt es hier.

 


 

Download unseres alten ROOT-Zertifikates SSL Ok

Certificate purposes:

SSL client : Yes
SSL client CA : Yes
SSL server : Yes
SSL server CA : Yes
Netscape SSL server : Yes
Netscape SSL server CA : Yes
S/MIME signing : Yes
S/MIME signing CA : Yes
S/MIME encryption : Yes
S/MIME encryption CA : Yes
CRL signing : Yes
CRL signing CA : Yes
Any Purpose : Yes
Any Purpose CA : Yes
OCSP helper : Yes
OCSP helper CA : Yes
MD5 Fingerprint = 31:EA:97:1D:79:D4:40:0B:EF:E1:ED:B9:D9:94:46:6F

Safe Search

Web-Of-Trust bündelt seine Filter und Sicherheitsregeln im neuen MyWOT.

Ziel ist es mit einem verbesserten und erweiterten Netzwerk an Usern und WebSite-Betreibern eine bessere und größere Basis zu schaffen. Das neue Browser Plugin filtert nun Aufrufe von WebSites schon im Vorfeld und kann auch in der Suche gefilterte und sichere Suchergebnisse anzeigen.

Dadurch ist ein sicheres surfen im Netz möglich, speziell können so Kinder vor schädlichen Internetseiten geschützt werden.

Taskplaner Aufgabenplaner Tab Einstellungen

Windows Aufgabenplanung Meldung (0x10)

Eigentlich doch eine ganz einfache Sache: Wir wollen einen robocopy-Befehl mit der Aufgabenplanung täglich starten, um Dateien zu synchronisieren.

Das ist auch wunderbar schnell eingerichtet. Es wird dazu eine BatchDatei erstellt mit einem Inhalt wie dem folgenden:

robocopy /B /E /COPYALL /PURGE /R:0 /W:0 /LOG:c:\temp\robocopy_%date%.txt H:\ \\fs\sicherung

Ein Doppelklick auf die Datei arbeitet wie erwartet…

Der Task selbst wird dann mit dem Taskplaner eingerichtet und als Admin gestartet.

ABER: Es passiert nichts und das „Ergebnis der letzten Ausführung“ bleibt immer (0x10)

Leider findet man weder im Eventlog noch im Taskplaner selbst irgendwelche Hinweise warum das scheitert.

Es gibt dazu mehrere Lösungen, bzw. mehrere Gründe warum es nicht funktionieren könnte.

z.B. könnte der eingetragene User zuwenig Rechte haben, oder zur Laufzeit des Tasks ist z.B. das Laufwerk H:\ gar nicht verbunden – dazu findet man viele Infos im Netz (net use H:\ …)

Bei uns war die Lösung allerdings folgende:

 Im Tab „Einstellungen“
  Folgende Regel anwenden, falls die Aufgabe bereits ausgeführt wird: „Neue Instanz parallel ausführen“

Aus irgend einem Grund war Windows der Meinung, dass es schon eine Instanz geben würde – obwohl im Taskmanager nichts davon zu sehen war – mit dieser Einstellung klappt es dann…

Taskplaner Aufgabenplaner Tab Einstellungen

aktuelles Phishing Mail versucht Mail-Passwörter abzufragen

Wieder mal müssen wir vor einem Phishing Mail warnen – in diesem Fall betrifft es nicht Banken, Kreditkarten oder Paypal-Konten, sondern Ihr Mailkonto.

Das Mail sieht wie folgt aus:

Betreff: Sehr geehrter Nutzer
Datum: Wed, 30 Apr 2014 00:02:12 +0100
Von: ADMIN<admin@webmail.net>
Antwort an: 647812717@qq.com
An: Recipients <admin@webmail.net>

Sehr geehrter Nutzer Ihre E-Mail wurde von 2 GB, der durch den Webmaster erstellt wird überschritten, die derzeit auf 2.30GB läuft, können Sie nicht, bis Sie Ihr Konto zu überprüfen senden oder zu empfangen neue Nachrichten. Füllen Sie das untenstehende Formular aus, um Ihr Konto zu überprüfen. Bitte füllen Sie das Formular aus, um Ihr Konto zu bestätigen

(1) E-mail:
(2) Name:
(3) Passwort:
(4) Passwort bestätigen:

danke Administrator von sistem

 

Wie bei allen Phishing-Mails ist auf eine solche Anfrage nicht zu antworten und in gar keinem Fall einfach ein Passwort an irgend einen dubiosen Administrator zu schicken…

Auch wenn der Absender in diesem Fall nicht auf „Graz4u“ gefälscht war und es dadurch eher leicht zu erkennen ist, dass es sich hier um eine Fälschung handelt, müssen wir hier nochmals ausdrücklich schreiben, dass wir Sie niemals auffordern und Ihre Zugangsdaten zu schicken!

Passwörter werden von uns ggf. maximal zurückgesetzt und Sie davon informiert. Bei der Überschreitung von Postfachgrößen werden Sie zwar informiert, Sie brauchen und aber weder E-Mail noch Name zurückschicken.

Weiters empfehlen wir Ihnen, sich immer zu vergewissern, dass wirklich „support@graz4u.at“ in der Empfängerzeile steht und nicht wie oben etwa „647812717@qq.com“

Microsoft Access funktioniert nicht mehr

Meldung „Microsoft Access funktioniert nicht mehr“

Eine ungute Sache: Nachdem man tagelang problemlos mit einer Access-Datei gearbeitet hat, kommt beim Versuch diese zu starten plötzlich die Meldung:

„Microsoft Access funktioniert nicht mehr“

Microsoft Access funktioniert nicht mehr

 

 

In den Problemdetails findet man dann noch:

Problemsignatur:
  Problemereignisname:    APPCRASH
  Anwendungsname:    MSACCESS.EXE
  Anwendungsversion:    14.0.6024.1000
  Anwendungszeitstempel:    4d83e4fc
  Fehlermodulname:    VBE7.DLL
  Fehlermodulversion:    7.0.16.19
  Fehlermodulzeitstempel:    4d430aec
  Ausnahmecode:    c0000005
  Ausnahmeoffset:    00023081
  Betriebsystemversion:    6.1.7601.2.1.0.16.7
  Gebietsschema-ID:    1031

Zusatzinformationen zum Problem:
  LCID:    1031
  skulcid:    1031

Lesen Sie unsere Datenschutzbestimmungen online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
  C:Windowssystem32de-DEerofflps.txt

 

Lösung:

Access 2010  (Access 2007)

Wir konnten das Problem mit einem früher schon mal beschriebenen Problem in Verbindung bringen – wie dort ist die Lösung auch hier der „decompile“ Parameter:

„C:Program Files (x86)Microsoft OfficeOffice14MSACCESS.EXE“ /decompile
danach einfach über „Datei öffnen“ die korrupte Datei öffnen
oder:
„C:Program Files (x86)Microsoft OfficeOffice14MSACCESS.EXE“ /decompile Pfad/und/Name/der/datei.mdb

 

Tags: „Microsoft Access“, „Access 2003“, „Access 2007“, „Access 2010“, „Access APPCRASH“, „Microsoft Access funktioniert nicht mehr“

 

In Windows ungültige Geräte löschen

Nicht angeschlossene, ausgebaute oder defekte Geräte können unter Windows oft zu Konflikten oder eigenartigem Verhalten führen. Derartige Geräte werden aber im Regelfall nicht angezeigt. Somit ist das deinstallieren dieser „alten“ Geräte nicht so einfach.

Wie kann man nun solche Geräte oder viel mehr deren Treiber und Einstellungen los werden?

Das geht prinzipiell mit dem Gerätemanager, den muß man aber mit einem speziellen Trick aufrufen um die verstecken Geräte zu sehen!

Gehen Sie am Besten wie folgt vor:

  • Eingebeaufforderung „cmd“ öffnen
  • auf der Kommandozeile folgendes eingeben:
      set DEVMGR_SHOW_NONPRESENT_DEVICES=1
      devmgmt.msc
  • es öffnet sich nun der Gerätemanager
  • klicken Sie im Menü auf „Ansicht“ und dann auf „Ausgeblendete Geräte anzeigen“
  • es werden nun alle Geräte angezeigt, Sie können das betreffende Gerät ganz normal deinstallieren

ACHTUNG: Es werden möglicherweise nun einige Geräte angezeigt die das System aber braucht & aus Sicherheitsgründen verborgen hat! Stellen Sie sicher wirklich NUR das Gerät zu deinstallieren das Sie nicht mehr benötigen! graz4u kann keine Haftung oder Verantwortung übernehmen wenn Sie falsche oder zu viele Geräte deinstallieren!

Joomla Upgrade 3.2.3 setzt „0“ hinter das Suchfeld

Frage: Seit dem letzten Upgrade auf Joomla 3.2.3 steht hinter dem Suchfeld eine Null (0) die ich nicht mehr wegbekomme…

Das liegt an folgender Zeile in mod_search.php:

$button = $params->get(‚button‘, ‚0‘);

Die Antwort haben wir hier gefunden – allerdings hat das nicht ganz funktioniert, denn wenn die Variable wie im Beitrag beschrieben einfach ausgeblendet wird, bekommen wir möglicherweise eine Fehlermeldung:

Notice: Undefined variable: button in …./plugins/system/t3/base/html/mod_search/default.php on line 17
Notice: Undefined variable: button in …./plugins/system/t3/base/html/mod_search/default.php on line 37

Wenn diese sogar nicht am Bildschirm erscheint, müllt sie in jedem Fall das Logfile bei jedem Seitenaufruf zu…

Die richtige Lösung ist in diesem Fall:

cd mod_search
editiere die Datei …/modules/mod_search/mod_search.php

Zeile 28 kopieren, auskommtieren und wie folgt ändern:

//$button         = $params->get(‚button‘, 0);
$button         = “;

Dadurch ist die Variable nicht undefiniert. Der Versuch die Zeile auf $params->get(‚button‘, ‚0‘); oder $params->get(‚button‘, “); zu ändern hat nichts gebracht.

Achtung: da dieses Verhalten von einigen Usern bereits in der Version 3.2.1 beschrieben wurde und bei uns erst mit 3.2.3 aufgetaucht ist, scheint es eine andere Abhängigkeit zu geben – daher ist dieser Hack bei den betroffenen Installationen eventuell auch bei späteren Upgrades wieder zu machen…