sap_xml_fehler02

SAP schwarzer Bildschirm

Problem: Kurz nach der Installation einer neuen Version des SAP-GUIs gibt es ein Problem beim Start des Programms – nach einigen erfolglosen Versuchen das Problem zu beheben wird der GUI deinstalliert und neu installiert – mit dem Erfolg, dass nun statt dem GUI nur noch ein schwarzes Fenster am Bildschirm erscheint – auch nach der Neuinstallation kann also nicht mit SAP-Client gearbeitet werden.

 

sap_xml_fehler02

Die Meldung weist also bereits darauf hin, dass eine XML-Datei nicht „analysiert“ werden kann. Da es nur ein Abbrechen gibt kann der GUI danach nicht gestartet werden.

Weiters findet man im oben beschriebenen Log: (saplgmgr_7456.tcr)

(Error)                       : CParser::Parse_From_File_Int: Could not initialize XML DOM!
(Error)(19.11.12 07:35:44.079): CParser::Parse_From_File_Int: Could not initialize XML DOM!
(Error)(19.11.12 07:35:46.519): CParser::Serialize_To_File_Int: Could not initialize XML DOM!

Im hier beschriebenen Fall geht SAP dann gar nicht auf, es kann aber auch sein, das sich der Client öffnen lässt und dann einfach schwaz und somit unbedienbar ist.

Ein weiteres Indiz für diesen Fehler ist, wenn folgende Meldung beim Start der SAP-Logon.exe kommt:

sap_xml_fehler01

SAP-GUI-Sicherheit, System versucht, auf die Datei C:\Program Files (x86\SAPFrontEnd\SAPgui\themes\enjoy\theme.xml zuzugreifen. Möchten Sie den Zugriff auf diese Datei zulassen?

Egal ob man „immer zulassen“ oder eine andere Variante wählt kommt danach entweder der schwarze Schirm oder oben beschriebene Fehlermeldung…

Das SAP-Logon-Fenster geht wohlgemerkt immer auf – nur der echte Client nicht, aber auch hier gibt es Probleme. Auf der Linken Seite des SAP-Logons findet man nicht die drei Verknüfungen „Favoriten, Verknüpfungen, Verbindungen“ – die resultiert aus der oben genannten Fehlermeldung bezüglich „Treeview“

Lösung:

Der Microsoft XML-Parser hat nicht mehr richtig funktioniert. (beschädigt?) Dieses Programm wird bei der Deinstallation von SAP anscheinend nicht deinstalliert und im folgenden auch nicht merh neu installiert:
Je nach Stand des Clients sind folgende Programme über Software/Progamme zu deinstallieren und wieder zu Installieren

MSXML 4.0 SP2 (KB954430) – gui720\GUI\WINDOWS\WIN32\system\msxml4.msi
MSXML 4.0 SP3                 – gui720_c3\GUI\WINDOWS\WIN32\system\msxml4.msi

Danach können die XML-Files wieder richtig interpretiert werden – keine der beiden Grafiken von oben sollte mehr erscheinen und SAP sofort wieder mit dem Splashscreen starten.

Links zu Beiträgen mit ähnlichen Problemen: SAP GUI only black after Upgrade

Posted in FAQs and tagged .