outlook_mailto12

Outlook 2010, Probleme nach Klick auf einen Mailto:Link

Ein Kunde meldet uns das Problem, dass er bestimmte Mails immer als unzustellbar zurück bekommt, obwohl er die Mailadresse mit CopyPaste eingegeben hat, bzw. wie es sich später herausstellt, durch klicken auf einen Mailto:Link in einer Mail.
Hier würde man ja annehmen, dass wirklich nichts falsch gemacht werden kann – ist aber nicht so, es handelt sich letztlich um ein nicht ganz unkompliziertes Problem von Outlook 2007 und 2010 für das es bisher keinen richtigen Hotfix zu geben scheint. (Immerhin ist das Problem selbst bereits lange bekannt und viel diskutiert)

Hier die Fehlermeldung die der User sofort nach dem Senden direkt vom Exchange-Server bekommt:

Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.

 Betreff: Test Gesendet am: 20.09.2012 16:51
Folgende(r) Empfänger kann/können nicht erreicht werden: 'friedrich.koelbel@kmf.co.at' am 20.09.2012 16:51 Die Nachricht konnte nicht übermittelt werden, weil das E-Mail-System des Empfängers unbekannt oder ungültig ist. Überprüfen Sie die Adresse,
 und wiederholen Sie den Vorgang, oder wenden Sie sich an Ihren
 Systemadministrator, um die Verbindung mit dem E-Mail-System des Empfängers zu überprüfen.

<mail.domain.at #5.1.2>

Die Adresse ist also 100% richtig geschrieben, wie kann es dann aber zu dieser Fehlermeldung kommen?

Im Grunde weisen bereits die einfachen Hochkomma (‚) in welche die Mailadresse eingebettet ist daraufhin, ein Blick in die ExchangeServer Verwaltung zeigt uns das eigentliche Problem: In der An:Zeile steht vor der Mailadresse ein „MAILTO:“ das hier nicht hingehört…

outlook_mailto12

Soweit so gut, aber auch jeder andere Versuch des Users, die Adresse neu einzugeben scheitert immer wieder mit dem selben Ergebnis – die Adresse wurde durch den Vorgang in den Adress-Cache von Outlook geschrieben und zieht immer wieder, auch wenn man versucht die Adresse händisch nochmals einzugeben.

Es erreichte uns übrigens eine zweite Fehlermeldung die uns etwas schneller auf die Spur brachte:

 Ihre Nachricht hat einige oder alle Empfänger nicht erreicht.
Betreff: WG: Subject
Gesendet am: 20.09.2012 11:51
 
Folgende(r) Empfänger kann/können nicht erreicht werden:
 MAILTO:name@domain.dlt am 20.09.2012 11:51

Die Nachricht konnte nicht übermittelt werden, weil das E-Mail-System des Empfängers
 unbekannt oder ungültig ist.  Überprüfen Sie die Adresse, und wiederholen Sie den
 Vorgang, oder wenden Sie sich an Ihren Systemadministrator,  um die Verbindung
 mit dem E-Mail-System des Empfängers zu überprüfen.

<mail.domain.at #5.1.2>

Laut verschiedenen Foreneinträgen handelt es sich um ein generelles Problem von Outlook 2007/2010 – wir stellen das Problem hier nach, um eine möglichst einfache Lösung für den User zu finden, der weder am Exchangeserver oder Mailserver-log nachsehen kann, und sich möglicherweise auch keine Hotfixes installieren kann (wie in unserem Fall wegen einer TerminalServer Session ohne Admin-Rechte).
Das angesprochene Hotfix löst im Übrigen auch nicht das Problem im Outlook, sondern es ändern nur die Erstellung von Mailto:Links in allen anderen Office-Programmen, wenn die Links von externen Mails weiterhin im Mailto:Format daherkommen. ändert das aber am Verhalten von Outlook gar nichts…

Um das Problem nachzustellen, genügt es ein beliebiges externes Mail (an sich selbst) weiter zu leiten – dadurch erscheint dann der Mailto:Link – auf ähnliche Weise ist auch das Problem des Users entstanden.

outlook_mailto02

Durch einen Klick auf den Mailto:link erscheint ein neues Mail in dem für einige Zeit die Adresse [mailto:adresse@domain] steht. (das ist eigentlich schon falsch)

outlook_mailto03

Nach einiger Zeit wechselt die Anzeige auf adresse@domain – hier ist doch eigentlich kein Fehler mehr zu erkennen! Und dennoch birgt diese Adresse die auch sofort in den Cache wandert nun zwei Probleme:

outlook_mailto04

Schickt man die Mail nun so ab, erhält man sofort die oben genannte Fehlermeldung:

outlook_mailto05

Gibt man nun die Adresse ein weiteres Mal ein (ein Teil reicht, sie wird aus dem Cache geholt) und macht einen Doppelklick darauf wird einem nichts auffallen – scheint alles OK:

outlook_mailto06

Kein „Mailto“ weit und breit! Trotzdem funktioniert es weiterhin nicht. Was ein sehr geschultes Auge sehen könnte: rechts unten, etwas über dem leeren Balken für Kontakt müsste eigentlich „Kontakt öffne“ stehen (siehe übernächste Screenshot) – dies ist hier der einzige Hinweis, dass die Adresse irgendwie nicht funktioniert…
Im übrigen scheint diese Adresse auch nicht bei den „Vorgeschlagenen Kontakten“ auf – irgendwie scheint sie nur im Cache zu existieren.

Den Cache kann man übrigens auf zwei Arten loswerden: Zum einen kann man den gesamten Cache in den Optionen löschen, oder aber man gibt einen Teil des Namens ein und klickt dann auf das X im Vorschlag.

outlook_mailto09

Interessanterweise hat diese Vorgehensweise bei uns übrigens NICHT funktioniert – nach dem Löschen brachte eine weitere Eingabe der Adresse mit der Hand wieder dasselbe Ergebnis… Wir haben das nicht mehr weiter getestet, für einzelne User wird das hier aber vielleicht schon die Lösung gewesen sein

Der nächste Ansatz war, auf die (blaue) Mailadresse im mittleren Bereich doppelt zu klicken, was eine neue Mail mit ebendieser Mailadresse aufmacht – ein Doppelklick auf diese Adresse zeigt nun plötzlich rechts unten „Kontakt öffnen“ unser erster Hinweis, dass es nun klappen könnte, und tatsächlich: Die Mail lässt sich nun absenden!
outlook_mailto07

Allerdings birgt diese Methode nochmal einen Fatalen Fehler: Da ich an ein „Nicht Exchange“-Konto geschickt habe, kam die Mail dort verstümmelt ohne Umlaute an, eine testweise eingebettete Grafik wurde zu einem Anhang namens Winmail.dat (!)

Und hier die endgültige Lösung des Problems:

Durch den Klick auf den Mailto:link wurde die Adresse mit einem falschen E-Mail-Typ gespeichert, den es nun zu ändern gilt:

In die E-Mail-Eigenschaften kommen Sie entweder, indem sie über die Mailadresse fahren und dort mit der Maus verweilen oder wieder den Doppelklick machen und dann im der grafischen Menü das ein Blatt darstellt (Weitere Optionen für die Interaktion mit dieser Person) klicken und dann „Outlook Eigenschaften“ auswählen.

outlook_mailto13

Wenn der falsche E-Mail-Typ eingetragen war, dann kommt hier sofort folgendes Fenster, ansonsten kommt bereits die Ansicht des Kontaktes (analog wie oben gezeigt, ob „Kontakt bearbeiten“ angezeigt wird, oder nicht)

outlook_mailto10

Hier sieht man nun, dass der E-Mail-Typ falsch ist, mit einem Klick auf „Internettyp“ wechselt der Typ auch sofort auf ein nicht mehr veränderbares „SMTP“ – diesen Effekt hatte auch schon die oben genannte Methode, aus dem einen Mail ein zweites aufzumachen – hier aber haben wir nun die Möglichkeiten auch das „Internetformat“ von „Im Outlook-Rich-Text-Format senden“ auf „Outlook wählt das optimale Sendeformat“ zu wechseln, denn genau dieser Punkt war der Grund, dass die Mail dann verstümmelt und mit einem winmail.dat beim Empfänger angekommen ist.

outlook_mailto11

Ein „OK“ an dieser Stelle aktualisiert auch sofort den Cache, danach kann man ganz normal an diese Adresse senden…

Kommt bei Ihnen übrigens bei „Outlook Eigenschaften“ statt dem Eigenschaftsfenster ein Kontaktfenster und sie wollen das Internetformat trotzdem ändern, dann wiederholen Sie den Vorgang hier in diesem Dialog an der Zeile E-Mail – nochmals mit der Maus über der Adresse verweilen und nochmals wie oben auf das Blatt und „Outlook Eigenschaften“ auswählen – danach kommt dann endlich wirklich der oben gezeigte Eigenschaftsdialog.

outlook_mailto14

Posted in FAQs and tagged , .